yum updateしたらUSB-NICが動かなくなった

USB有線NICが認識しなくなりました・・・

おそらく、皆さんは、こんなことで困る人はいないと思いますが・・・6.9の環境でyum updateを実行したら、それまで使えていたUSB NICが認識されなくなってしまいました。

この検証環境は、以前、記事にした環境と同じくVAIO Type-PにロジテックLAN-TXU2CというUSB LANアダプターを接続しています。以前に記事とは CentOSのバージョンが6.8と6.9で異なっていますが、実施している内容は同じです。

VAIO Type-Pを使用して、自宅環境(小規模オフィスを想定)にWordPress環境を構築(CentOS6.8編) 第1回

CentOS6.9の状態でLANP+WordPressという環境にしていましたが、今回、yum updateを実施しておこうと思い立ち、軽い気持ちで実施しました。

yum updateを実施したら

yum updateを実行後、サーバを再起動したところ、ネットワークに接続できなくなったため、ipコマンドでインターフェースの確認をしたところ、USB LANアダプターが認識されていませんでした。

###正常時

[root@centos69-vaiop-100 ~]# ip a
1: lo:  mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth1:  mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 34:95:db:28:f2:29 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.100/24 brd 192.168.0.255 scope global eth1
    inet6 240f:7e:8dab:1:3695:dbff:fe28:f229/64 scope global dynamic 
       valid_lft 298sec preferred_lft 298sec
    inet6 fe80::3695:dbff:fe28:f229/64 scope link 
       valid_lft forever preferred_lft forever
3: eth0:  mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:1d:ba:6b:eb:dd brd ff:ff:ff:ff:ff:ff
4: wlan0:  mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:23:4d:e0:6b:48 brd ff:ff:ff:ff:ff:ff

USB LANアダプターが認識されていない状態

[root@centos69-vaiop-100 ~]# ip a
1: lo:  mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0:  mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:1d:ba:6b:eb:dd brd ff:ff:ff:ff:ff:ff
3: wlan0:  mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:23:4d:e0:6b:48 brd ff:ff:ff:ff:ff:ff

切り分けしてみます

  • USB LANアダプターを認識していないのか?
    繋がっていることは認識しているようです
  • [root@centos69-vaiop-100 ~]# dmesg | grep ‘usb 1-1’
    usb 1-1: new high speed USB device number 2 using ehci_hcd
    usb 1-1: New USB device found, idVendor=0b95, idProduct=772b
    usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    usb 1-1: Product: AX88772B
    usb 1-1: Manufacturer: ASIX Elec. Corp.
    usb 1-1: SerialNumber: 28F229
    usb 1-1: configuration #1 chosen from 1 choice
    
  • /sys/class/netのリンクを確認
    eth1のリンクが無いです
  • [root@centos69-vaiop-100 ~]# ls /sys/class/net
    eth0  lo  wlan0
    
  • Driverが動作していないのか?
    なにやら動いているようです
  • [root@centos69-vaiop-100 ~]# lsmod |grep asix
    asix                   46686  0 
    mii                     4476  1 asix
    
  • エラーが発生していないか?
    と思いましたが、解らず・・・

yum updateの状態

yum updateを実行して放置してしまったので確認していませんでしたが、kernel-2.6.32-696.13.2.el6.i686というのが追加されているようです。
yum update前

kernel-2.6.32-696.el6.i686
kernel-devel-2.6.32-696.el6.i686
kernel-headers-2.6.32-696.el6.i686

yum update後

kernel-2.6.32-696.el6.i686
kernel-firmware-2.6.32-696.13.2.el6.noarch
kernel-2.6.32-696.13.2.el6.i686
dracut-kernel-004-409.el6_8.2.noarch
kernel-devel-2.6.32-696.el6.i686
kernel-headers-2.6.32-696.13.2.el6.i686
kernel-devel-2.6.32-696.13.2.el6.i686

とりあえず回避

kernel-2.6.32-696.13.2.el6.i686に対応するDriverなりがないのかな?と思い、起動時にkernel-2.6.32-696.el6.i686を選択して起動してみます。

立ち上がるとUSB LANアダプターを認識していました。良かった良かったということですが、これでいいのか?という気もしますが、今日は、ここまでにすることにしました。

スポンサーリンク
spdsk-side
spdsk-side