yum updateが/bootの容量不足で失敗しました

yum updateが/bootの容量不足で失敗しました

yum updateを実行しようとしたところ、/bootが容量不足で実行できませんでした。元々200MBしか取っていなかったので自業自得ですが。Redhatのインストールガイドでは1GBあれば十分と言っているので1/5です。

Redhat Enterprise Linux7 インストールガイド
https://access.redhat.com/documentation/ja-jp/red_hat_enterprise_linux/7/html/installation_guide/sect-disk-partitioning-setup-x86#sect-custom-partitioning-x86

# yum update
読み込んだプラグイン:fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * epel: epel.scopesky.iq
 * extras: ftp.iij.ad.jp
 * updates: ftp.iij.ad.jp
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ iptables.x86_64 0:1.4.21-18.2.el7_4 を 更新
---> パッケージ iptables.x86_64 0:1.4.21-18.3.el7_4 を アップデート
---> パッケージ kernel.x86_64 0:3.10.0-693.21.1.el7 を インストール
---> パッケージ kernel-tools.x86_64 0:3.10.0-693.17.1.el7 を 更新
---> パッケージ kernel-tools.x86_64 0:3.10.0-693.21.1.el7 を アップデート
---> パッケージ kernel-tools-libs.x86_64 0:3.10.0-693.17.1.el7 を 更新
---> パッケージ kernel-tools-libs.x86_64 0:3.10.0-693.21.1.el7 を アップデート
---> パッケージ libgcc.i686 0:4.8.5-16.el7_4.1 を 更新
---> パッケージ libgcc.x86_64 0:4.8.5-16.el7_4.1 を 更新
---> パッケージ libgcc.i686 0:4.8.5-16.el7_4.2 を アップデート
---> パッケージ libgcc.x86_64 0:4.8.5-16.el7_4.2 を アップデート
---> パッケージ libgomp.x86_64 0:4.8.5-16.el7_4.1 を 更新
---> パッケージ libgomp.x86_64 0:4.8.5-16.el7_4.2 を アップデート
---> パッケージ libgudev1.x86_64 0:219-42.el7_4.7 を 更新
---> パッケージ libgudev1.x86_64 0:219-42.el7_4.10 を アップデート
---> パッケージ libstdc++.i686 0:4.8.5-16.el7_4.1 を 更新
---> パッケージ libstdc++.x86_64 0:4.8.5-16.el7_4.1 を 更新
---> パッケージ libstdc++.i686 0:4.8.5-16.el7_4.2 を アップデート
---> パッケージ libstdc++.x86_64 0:4.8.5-16.el7_4.2 を アップデート
---> パッケージ libteam.x86_64 0:1.25-5.el7 を 更新
---> パッケージ libteam.x86_64 0:1.25-6.el7_4.3 を アップデート
---> パッケージ python-perf.x86_64 0:3.10.0-693.17.1.el7 を 更新
---> パッケージ python-perf.x86_64 0:3.10.0-693.21.1.el7 を アップデート
---> パッケージ selinux-policy.noarch 0:3.13.1-166.el7_4.7 を 更新
---> パッケージ selinux-policy.noarch 0:3.13.1-166.el7_4.9 を アップデート
---> パッケージ selinux-policy-targeted.noarch 0:3.13.1-166.el7_4.7 を 更新
---> パッケージ selinux-policy-targeted.noarch 0:3.13.1-166.el7_4.9 を アップデート
---> パッケージ systemd.x86_64 0:219-42.el7_4.7 を 更新
---> パッケージ systemd.x86_64 0:219-42.el7_4.10 を アップデート
---> パッケージ systemd-libs.i686 0:219-42.el7_4.7 を 更新
---> パッケージ systemd-libs.x86_64 0:219-42.el7_4.7 を 更新
---> パッケージ systemd-libs.i686 0:219-42.el7_4.10 を アップデート
---> パッケージ systemd-libs.x86_64 0:219-42.el7_4.10 を アップデート
---> パッケージ systemd-sysv.x86_64 0:219-42.el7_4.7 を 更新
---> パッケージ systemd-sysv.x86_64 0:219-42.el7_4.10 を アップデート
---> パッケージ teamd.x86_64 0:1.25-5.el7 を 更新
---> パッケージ teamd.x86_64 0:1.25-6.el7_4.3 を アップデート
--> 依存性解決を終了しました。

依存性を解決しました

====================================================================================================
 Package                         アーキテクチャー
                                                バージョン                    リポジトリー     容量
====================================================================================================
インストール中:
 kernel                          x86_64         3.10.0-693.21.1.el7           updates          43 M
更新します:
 iptables                        x86_64         1.4.21-18.3.el7_4             updates         428 k
 kernel-tools                    x86_64         3.10.0-693.21.1.el7           updates         5.2 M
 kernel-tools-libs               x86_64         3.10.0-693.21.1.el7           updates         5.1 M
 libgcc                          i686           4.8.5-16.el7_4.2              updates         106 k
 libgcc                          x86_64         4.8.5-16.el7_4.2              updates          98 k
 libgomp                         x86_64         4.8.5-16.el7_4.2              updates         154 k
 libgudev1                       x86_64         219-42.el7_4.10               updates          85 k
 libstdc++                       i686           4.8.5-16.el7_4.2              updates         314 k
 libstdc++                       x86_64         4.8.5-16.el7_4.2              updates         301 k
 libteam                         x86_64         1.25-6.el7_4.3                updates          47 k
 python-perf                     x86_64         3.10.0-693.21.1.el7           updates         5.2 M
 selinux-policy                  noarch         3.13.1-166.el7_4.9            updates         437 k
 selinux-policy-targeted         noarch         3.13.1-166.el7_4.9            updates         6.5 M
 systemd                         x86_64         219-42.el7_4.10               updates         5.2 M
 systemd-libs                    i686           219-42.el7_4.10               updates         378 k
 systemd-libs                    x86_64         219-42.el7_4.10               updates         378 k
 systemd-sysv                    x86_64         219-42.el7_4.10               updates          72 k
 teamd                           x86_64         1.25-6.el7_4.3                updates         112 k

トランザクションの要約
====================================================================================================
インストール   1 パッケージ
更新          18 パッケージ

合計容量: 73 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  installing package kernel-3.10.0-693.21.1.el7.x86_64 needs 31MB on the /boot filesystem

エラーの要約
-------------
ディスク要求:
  少なくとも 31MB の空き容量がファイルシステム /boot で必要です。

/bootを確認

/bootの状況を確認してみます。

# df -m /boot
ファイルシス   1M-ブロック  使用 使用可 使用% マウント位置
/dev/sda1              190   186      0  100% /boot

# ll /boot
合計 180538
-rw-------. 1 root root  3113253 11月 23  2016 System.map-3.10.0-514.el7.x86_64
-rw-------. 1 root root  3232490  1月  4 10:19 System.map-3.10.0-693.11.6.el7.x86_64
-rw-------. 1 root root  3232454  1月 26 05:26 System.map-3.10.0-693.17.1.el7.x86_64
-rw-r--r--. 1 root root   137696 11月 23  2016 config-3.10.0-514.el7.x86_64
-rw-r--r--. 1 root root   140915  1月  4 10:19 config-3.10.0-693.11.6.el7.x86_64
-rw-r--r--. 1 root root   140915  1月 26 05:26 config-3.10.0-693.17.1.el7.x86_64
drwxr-xr-x. 3 root root     1024  1月 22 09:56 efi
drwxr-xr-x. 2 root root     1024  1月 22 09:21 grub
drwx------. 5 root root     1024  2月 28 11:58 grub2
-rw-------. 1 root root 45006822  1月 22 09:25 initramfs-0-rescue-732cbc8559b0422f8ea98b5dbdef90aa.img
-rw-------. 1 root root 18556056  1月 22 09:59 initramfs-3.10.0-514.el7.x86_64.img
-rw-------. 1 root root 16912595  1月 22 09:58 initramfs-3.10.0-514.el7.x86_64kdump.img
-rw-------. 1 root root 18645377  1月 22 09:59 initramfs-3.10.0-693.11.6.el7.x86_64.img
-rw-------. 1 root root 16669475  1月 22 10:01 initramfs-3.10.0-693.11.6.el7.x86_64kdump.img
-rw-------. 1 root root 18315777  2月 28 11:58 initramfs-3.10.0-693.17.1.el7.x86_64.img
-rw-------. 1 root root 16673836  3月  1 09:15 initramfs-3.10.0-693.17.1.el7.x86_64kdump.img
-rw-r--r--. 1 root root   611343  1月 22 09:58 initrd-plymouth.img
drwx------. 2 root root    12288  1月 22 09:21 lost+found
-rw-r--r--. 1 root root   277953 11月 23  2016 symvers-3.10.0-514.el7.x86_64.gz
-rw-r--r--. 1 root root   293110  1月  4 10:21 symvers-3.10.0-693.11.6.el7.x86_64.gz
-rw-r--r--. 1 root root   293109  1月 26 05:28 symvers-3.10.0-693.17.1.el7.x86_64.gz
-rwxr-xr-x. 1 root root  5392080  1月 22 09:25 vmlinuz-0-rescue-732cbc8559b0422f8ea98b5dbdef90aa
-rwxr-xr-x. 1 root root  5392080 11月 23  2016 vmlinuz-3.10.0-514.el7.x86_64
-rwxr-xr-x. 1 root root  5889728  1月  4 10:19 vmlinuz-3.10.0-693.11.6.el7.x86_64
-rwxr-xr-x. 1 root root  5890720  1月 26 05:26 vmlinuz-3.10.0-693.17.1.el7.x86_64

yum-utilsをインストール

根本解決にはなっていませんが、とりあえずyum-utilsをインストールして必要の無いkernelを削除してみましょう。

# yum install yum-utils
読み込んだプラグイン:fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * epel: epel.scopesky.iq
 * extras: ftp.iij.ad.jp
 * updates: ftp.iij.ad.jp
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ yum-utils.noarch 0:1.1.31-42.el7 を インストール
--> 依存性の処理をしています: python-kitchen のパッケージ: yum-utils-1.1.31-42.el7.noarch
--> 依存性の処理をしています: libxml2-python のパッケージ: yum-utils-1.1.31-42.el7.noarch
--> トランザクションの確認を実行しています。
---> パッケージ libxml2-python.x86_64 0:2.9.1-6.el7_2.3 を インストール
---> パッケージ python-kitchen.noarch 0:1.1.1-5.el7 を インストール
--> 依存性の処理をしています: python-chardet のパッケージ: python-kitchen-1.1.1-5.el7.noarch
--> トランザクションの確認を実行しています。
---> パッケージ python-chardet.noarch 0:2.2.1-1.el7_1 を インストール
--> 依存性解決を終了しました。

依存性を解決しました

====================================================================================================
 Package                    アーキテクチャー   バージョン                    リポジトリー      容量
====================================================================================================
インストール中:
 yum-utils                  noarch             1.1.31-42.el7                 base             117 k
依存性関連でのインストールをします:
 libxml2-python             x86_64             2.9.1-6.el7_2.3               base             247 k
 python-chardet             noarch             2.2.1-1.el7_1                 base             227 k
 python-kitchen             noarch             1.1.1-5.el7                   base             267 k

トランザクションの要約
====================================================================================================
インストール  1 パッケージ (+3 個の依存関係のパッケージ)

総ダウンロード容量: 857 k
インストール容量: 4.3 M
Is this ok [y/d/N]: y
Downloading packages:
(1/4): python-chardet-2.2.1-1.el7_1.noarch.rpm                               | 227 kB  00:00:03
(2/4): libxml2-python-2.9.1-6.el7_2.3.x86_64.rpm                             | 247 kB  00:00:03
(3/4): python-kitchen-1.1.1-5.el7.noarch.rpm                                 | 267 kB  00:00:00
(4/4): yum-utils-1.1.31-42.el7.noarch.rpm                                    | 117 kB  00:00:00
----------------------------------------------------------------------------------------------------
合計                                                                227 kB/s | 857 kB  00:00:03
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  インストール中          : python-chardet-2.2.1-1.el7_1.noarch                                 1/4
  インストール中          : python-kitchen-1.1.1-5.el7.noarch                                   2/4
  インストール中          : libxml2-python-2.9.1-6.el7_2.3.x86_64                               3/4
  インストール中          : yum-utils-1.1.31-42.el7.noarch                                      4/4
  検証中                  : libxml2-python-2.9.1-6.el7_2.3.x86_64                               1/4
  検証中                  : yum-utils-1.1.31-42.el7.noarch                                      2/4
  検証中                  : python-kitchen-1.1.1-5.el7.noarch                                   3/4
  検証中                  : python-chardet-2.2.1-1.el7_1.noarch                                 4/4

インストール:
  yum-ut

古いカーネルを削除

package-cleanupコマンドで古いカーネルを削除します。ここでは残すバージョンを指定していませんが、何世代前まで残すかの設定もできます。

# package-cleanup --oldkernels
読み込んだプラグイン:fastestmirror
--> トランザクションの確認を実行しています。
---> パッケージ kernel.x86_64 0:3.10.0-514.el7 を 削除
--> 依存性解決を終了しました。

依存性を解決しました

====================================================================================================
 Package             アーキテクチャー    バージョン                    リポジトリー            容量
====================================================================================================
削除中:
 kernel              x86_64              3.10.0-514.el7                @anaconda              148 M

トランザクションの要約
====================================================================================================
削除  1 パッケージ

インストール容量: 148 M
上記の処理を行います。よろしいでしょうか? [y/N]y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  削除中                  : kernel-3.10.0-514.el7.x86_64                                        1/1
  検証中                  : kernel-3.10.0-514.el7.x86_64                                        1/1

削除しました:
  kernel.x86_64 0:3.10.0-514.el7

完了しました!
# df -m /boot
ファイルシス   1M-ブロック  使用 使用可 使用% マウント位置
/dev/sda1              190   144     33   82% /boot

# ll /boot
合計 137166
-rw-------. 1 root root  3232490  1月  4 10:19 System.map-3.10.0-693.11.6.el7.x86_64
-rw-------. 1 root root  3232454  1月 26 05:26 System.map-3.10.0-693.17.1.el7.x86_64
-rw-r--r--. 1 root root   140915  1月  4 10:19 config-3.10.0-693.11.6.el7.x86_64
-rw-r--r--. 1 root root   140915  1月 26 05:26 config-3.10.0-693.17.1.el7.x86_64
drwxr-xr-x. 3 root root     1024  1月 22 09:56 efi
drwxr-xr-x. 2 root root     1024  1月 22 09:21 grub
drwx------. 5 root root     1024  3月 13 13:01 grub2
-rw-------. 1 root root 45006822  1月 22 09:25 initramfs-0-rescue-732cbc8559b0422f8ea98b5dbdef90aa.img
-rw-------. 1 root root 18645377  1月 22 09:59 initramfs-3.10.0-693.11.6.el7.x86_64.img
-rw-------. 1 root root 16669475  1月 22 10:01 initramfs-3.10.0-693.11.6.el7.x86_64kdump.img
-rw-------. 1 root root 18315777  2月 28 11:58 initramfs-3.10.0-693.17.1.el7.x86_64.img
-rw-------. 1 root root 16673836  3月  1 09:15 initramfs-3.10.0-693.17.1.el7.x86_64kdump.img
-rw-r--r--. 1 root root   611343  1月 22 09:58 initrd-plymouth.img
-rw-r--r--. 1 root root   293110  1月  4 10:21 symvers-3.10.0-693.11.6.el7.x86_64.gz
-rw-r--r--. 1 root root   293109  1月 26 05:28 symvers-3.10.0-693.17.1.el7.x86_64.gz
-rwxr-xr-x. 1 root root  5392080  1月 22 09:25 vmlinuz-0-rescue-732cbc8559b0422f8ea98b5dbdef90aa
-rwxr-xr-x. 1 root root  5889728  1月  4 10:19 vmlinuz-3.10.0-693.11.6.el7.x86_64
-rwxr-xr-x. 1 root root  5890720  1月 26 05:26 vmlinuz-3.10.0-693.17.1.el7.x86_64

yum updateを試す

/bootに空きができたので、yum updateが実行できました。

# yum update
読み込んだプラグイン:fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * epel: epel.scopesky.iq
 * extras: ftp.iij.ad.jp
 * updates: ftp.iij.ad.jp
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ iptables.x86_64 0:1.4.21-18.2.el7_4 を 更新
---> パッケージ iptables.x86_64 0:1.4.21-18.3.el7_4 を アップデート
---> パッケージ kernel.x86_64 0:3.10.0-693.21.1.el7 を インストール
---> パッケージ kernel-tools.x86_64 0:3.10.0-693.17.1.el7 を 更新
---> パッケージ kernel-tools.x86_64 0:3.10.0-693.21.1.el7 を アップデート
---> パッケージ kernel-tools-libs.x86_64 0:3.10.0-693.17.1.el7 を 更新
---> パッケージ kernel-tools-libs.x86_64 0:3.10.0-693.21.1.el7 を アップデート
---> パッケージ libgcc.i686 0:4.8.5-16.el7_4.1 を 更新
---> パッケージ libgcc.x86_64 0:4.8.5-16.el7_4.1 を 更新
---> パッケージ libgcc.i686 0:4.8.5-16.el7_4.2 を アップデート
---> パッケージ libgcc.x86_64 0:4.8.5-16.el7_4.2 を アップデート
---> パッケージ libgomp.x86_64 0:4.8.5-16.el7_4.1 を 更新
---> パッケージ libgomp.x86_64 0:4.8.5-16.el7_4.2 を アップデート
---> パッケージ libgudev1.x86_64 0:219-42.el7_4.7 を 更新
---> パッケージ libgudev1.x86_64 0:219-42.el7_4.10 を アップデート
---> パッケージ libstdc++.i686 0:4.8.5-16.el7_4.1 を 更新
---> パッケージ libstdc++.x86_64 0:4.8.5-16.el7_4.1 を 更新
---> パッケージ libstdc++.i686 0:4.8.5-16.el7_4.2 を アップデート
---> パッケージ libstdc++.x86_64 0:4.8.5-16.el7_4.2 を アップデート
---> パッケージ libteam.x86_64 0:1.25-5.el7 を 更新
---> パッケージ libteam.x86_64 0:1.25-6.el7_4.3 を アップデート
---> パッケージ python-perf.x86_64 0:3.10.0-693.17.1.el7 を 更新
---> パッケージ python-perf.x86_64 0:3.10.0-693.21.1.el7 を アップデート
---> パッケージ selinux-policy.noarch 0:3.13.1-166.el7_4.7 を 更新
---> パッケージ selinux-policy.noarch 0:3.13.1-166.el7_4.9 を アップデート
---> パッケージ selinux-policy-targeted.noarch 0:3.13.1-166.el7_4.7 を 更新
---> パッケージ selinux-policy-targeted.noarch 0:3.13.1-166.el7_4.9 を アップデート
---> パッケージ systemd.x86_64 0:219-42.el7_4.7 を 更新
---> パッケージ systemd.x86_64 0:219-42.el7_4.10 を アップデート
---> パッケージ systemd-libs.i686 0:219-42.el7_4.7 を 更新
---> パッケージ systemd-libs.x86_64 0:219-42.el7_4.7 を 更新
---> パッケージ systemd-libs.i686 0:219-42.el7_4.10 を アップデート
---> パッケージ systemd-libs.x86_64 0:219-42.el7_4.10 を アップデート
---> パッケージ systemd-sysv.x86_64 0:219-42.el7_4.7 を 更新
---> パッケージ systemd-sysv.x86_64 0:219-42.el7_4.10 を アップデート
---> パッケージ teamd.x86_64 0:1.25-5.el7 を 更新
---> パッケージ teamd.x86_64 0:1.25-6.el7_4.3 を アップデート
--> 依存性解決を終了しました。

依存性を解決しました

====================================================================================================
 Package                         アーキテクチャー
                                                バージョン                    リポジトリー     容量
====================================================================================================
インストール中:
 kernel                          x86_64         3.10.0-693.21.1.el7           updates          43 M
更新します:
 iptables                        x86_64         1.4.21-18.3.el7_4             updates         428 k
 kernel-tools                    x86_64         3.10.0-693.21.1.el7           updates         5.2 M
 kernel-tools-libs               x86_64         3.10.0-693.21.1.el7           updates         5.1 M
 libgcc                          i686           4.8.5-16.el7_4.2              updates         106 k
 libgcc                          x86_64         4.8.5-16.el7_4.2              updates          98 k
 libgomp                         x86_64         4.8.5-16.el7_4.2              updates         154 k
 libgudev1                       x86_64         219-42.el7_4.10               updates          85 k
 libstdc++                       i686           4.8.5-16.el7_4.2              updates         314 k
 libstdc++                       x86_64         4.8.5-16.el7_4.2              updates         301 k
 libteam                         x86_64         1.25-6.el7_4.3                updates          47 k
 python-perf                     x86_64         3.10.0-693.21.1.el7           updates         5.2 M
 selinux-policy                  noarch         3.13.1-166.el7_4.9            updates         437 k
 selinux-policy-targeted         noarch         3.13.1-166.el7_4.9            updates         6.5 M
 systemd                         x86_64         219-42.el7_4.10               updates         5.2 M
 systemd-libs                    i686           219-42.el7_4.10               updates         378 k
 systemd-libs                    x86_64         219-42.el7_4.10               updates         378 k
 systemd-sysv                    x86_64         219-42.el7_4.10               updates          72 k
 teamd                           x86_64         1.25-6.el7_4.3                updates         112 k

トランザクションの要約
====================================================================================================
インストール   1 パッケージ
更新          18 パッケージ

合計容量: 73 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  更新します              : libgcc-4.8.5-16.el7_4.2.x86_64                                     1/37
  更新します              : systemd-libs-219-42.el7_4.10.x86_64                                2/37
  更新します              : libgcc-4.8.5-16.el7_4.2.i686                                       3/37
  更新します              : systemd-219-42.el7_4.10.x86_64                                     4/37
  更新します              : selinux-policy-3.13.1-166.el7_4.9.noarch                           5/37
  更新します              : libteam-1.25-6.el7_4.3.x86_64                                      6/37
  更新します              : kernel-tools-libs-3.10.0-693.21.1.el7.x86_64                       7/37
  更新します              : kernel-tools-3.10.0-693.21.1.el7.x86_64                            8/37
  更新します              : teamd-1.25-6.el7_4.3.x86_64                                        9/37
  更新します              : selinux-policy-targeted-3.13.1-166.el7_4.9.noarch                 10/37
  更新します              : systemd-sysv-219-42.el7_4.10.x86_64                               11/37
  更新します              : libgudev1-219-42.el7_4.10.x86_64                                  12/37
  更新します              : libstdc++-4.8.5-16.el7_4.2.x86_64                                 13/37
  更新します              : iptables-1.4.21-18.3.el7_4.x86_64                                 14/37
  インストール中          : kernel-3.10.0-693.21.1.el7.x86_64                                 15/37
  更新します              : libgomp-4.8.5-16.el7_4.2.x86_64                                   16/37
  更新します              : python-perf-3.10.0-693.21.1.el7.x86_64                            17/37
  更新します              : systemd-libs-219-42.el7_4.10.i686                                 18/37
  更新します              : libstdc++-4.8.5-16.el7_4.2.i686                                   19/37
  整理中                  : libstdc++-4.8.5-16.el7_4.1                                        20/37
  整理中                  : systemd-libs-219-42.el7_4.7                                       21/37
  整理中                  : selinux-policy-targeted-3.13.1-166.el7_4.7.noarch                 22/37
  整理中                  : systemd-sysv-219-42.el7_4.7.x86_64                                23/37
  整理中                  : systemd-219-42.el7_4.7.x86_64                                     24/37
  整理中                  : kernel-tools-3.10.0-693.17.1.el7.x86_64                           25/37
  整理中                  : teamd-1.25-5.el7.x86_64                                           26/37
  整理中                  : libgudev1-219-42.el7_4.7.x86_64                                   27/37
  整理中                  : systemd-libs-219-42.el7_4.7                                       28/37
  整理中                  : libstdc++-4.8.5-16.el7_4.1                                        29/37
  整理中                  : selinux-policy-3.13.1-166.el7_4.7.noarch                          30/37
  整理中                  : libgcc-4.8.5-16.el7_4.1                                           31/37
  整理中                  : libgcc-4.8.5-16.el7_4.1                                           32/37
  整理中                  : libteam-1.25-5.el7.x86_64                                         33/37
  整理中                  : kernel-tools-libs-3.10.0-693.17.1.el7.x86_64                      34/37
  整理中                  : iptables-1.4.21-18.2.el7_4.x86_64                                 35/37
  整理中                  : libgomp-4.8.5-16.el7_4.1.x86_64                                   36/37
  整理中                  : python-perf-3.10.0-693.17.1.el7.x86_64                            37/37
  検証中                  : libgcc-4.8.5-16.el7_4.2.i686                                       1/37
  検証中                  : libgcc-4.8.5-16.el7_4.2.x86_64                                     2/37
  検証中                  : python-perf-3.10.0-693.21.1.el7.x86_64                             3/37
  検証中                  : libgomp-4.8.5-16.el7_4.2.x86_64                                    4/37
  検証中                  : systemd-sysv-219-42.el7_4.10.x86_64                                5/37
  検証中                  : selinux-policy-targeted-3.13.1-166.el7_4.9.noarch                  6/37
  検証中                  : kernel-tools-libs-3.10.0-693.21.1.el7.x86_64                       7/37
  検証中                  : libteam-1.25-6.el7_4.3.x86_64                                      8/37
  検証中                  : systemd-libs-219-42.el7_4.10.x86_64                                9/37
  検証中                  : selinux-policy-3.13.1-166.el7_4.9.noarch                          10/37
  検証中                  : libstdc++-4.8.5-16.el7_4.2.x86_64                                 11/37
  検証中                  : systemd-219-42.el7_4.10.x86_64                                    12/37
  検証中                  : libgudev1-219-42.el7_4.10.x86_64                                  13/37
  検証中                  : kernel-3.10.0-693.21.1.el7.x86_64                                 14/37
  検証中                  : systemd-libs-219-42.el7_4.10.i686                                 15/37
  検証中                  : teamd-1.25-6.el7_4.3.x86_64                                       16/37
  検証中                  : libstdc++-4.8.5-16.el7_4.2.i686                                   17/37
  検証中                  : iptables-1.4.21-18.3.el7_4.x86_64                                 18/37
  検証中                  : kernel-tools-3.10.0-693.21.1.el7.x86_64                           19/37
  検証中                  : python-perf-3.10.0-693.17.1.el7.x86_64                            20/37
  検証中                  : libteam-1.25-5.el7.x86_64                                         21/37
  検証中                  : systemd-sysv-219-42.el7_4.7.x86_64                                22/37
  検証中                  : libgomp-4.8.5-16.el7_4.1.x86_64                                   23/37
  検証中                  : libgcc-4.8.5-16.el7_4.1.x86_64                                    24/37
  検証中                  : libstdc++-4.8.5-16.el7_4.1.i686                                   25/37
  検証中                  : teamd-1.25-5.el7.x86_64                                           26/37
  検証中                  : selinux-policy-3.13.1-166.el7_4.7.noarch                          27/37
  検証中                  : selinux-policy-targeted-3.13.1-166.el7_4.7.noarch                 28/37
  検証中                  : libgcc-4.8.5-16.el7_4.1.i686                                      29/37
  検証中                  : kernel-tools-3.10.0-693.17.1.el7.x86_64                           30/37
  検証中                  : kernel-tools-libs-3.10.0-693.17.1.el7.x86_64                      31/37
  検証中                  : systemd-libs-219-42.el7_4.7.i686                                  32/37
  検証中                  : libstdc++-4.8.5-16.el7_4.1.x86_64                                 33/37
  検証中                  : iptables-1.4.21-18.2.el7_4.x86_64                                 34/37
  検証中                  : systemd-219-42.el7_4.7.x86_64                                     35/37
  検証中                  : systemd-libs-219-42.el7_4.7.x86_64                                36/37
  検証中                  : libgudev1-219-42.el7_4.7.x86_64                                   37/37

インストール:
  kernel.x86_64 0:3.10.0-693.21.1.el7

更新:
  iptables.x86_64 0:1.4.21-18.3.el7_4                   kernel-tools.x86_64 0:3.10.0-693.21.1.el7
  kernel-tools-libs.x86_64 0:3.10.0-693.21.1.el7        libgcc.i686 0:4.8.5-16.el7_4.2
  libgcc.x86_64 0:4.8.5-16.el7_4.2                      libgomp.x86_64 0:4.8.5-16.el7_4.2
  libgudev1.x86_64 0:219-42.el7_4.10                    libstdc++.i686 0:4.8.5-16.el7_4.2
  libstdc++.x86_64 0:4.8.5-16.el7_4.2                   libteam.x86_64 0:1.25-6.el7_4.3
  python-perf.x86_64 0:3.10.0-693.21.1.el7              selinux-policy.noarch 0:3.13.1-166.el7_4.9
  selinux-policy-targeted.noarch 0:3.13.1-166.el7_4.9   systemd.x86_64 0:219-42.el7_4.10
  systemd-libs.i686 0:219-42.el7_4.10                   systemd-libs.x86_64 0:219-42.el7_4.10
  systemd-sysv.x86_64 0:219-42.el7_4.10                 teamd.x86_64 0:1.25-6.el7_4.3

完了しました!

yum update後の状態は、ほぼ空きがないので根本解決には/bootを増やすしかないですが、とりあえずの対処という記事でした。

# df -m /boot
ファイルシス   1M-ブロック  使用 使用可 使用% マウント位置
/dev/sda1              190   170      7   97% /boot
スポンサーリンク
spdsk-side
spdsk-side